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File Naming Conventions 
 
 
 
 

 
 
In this Chapter 
 
In this chapter, we will go over the file naming conventions contained in the A/E/C CADD 
Standard. These include: 
 

•= Model file naming 
•= Sheet file naming 

 
We will perform a quick exercise and then look at the File Manager program that is available. 



  Course Guide 
 

A/E/C CADD Standard Workspace 2.0 Course Guide  1-2 

File Names 
 
File naming is a vital part of the A/E/C Workspace. The checker used to ensure that all model 
files are compliant with the A/E/C CADD Standard reviews the file name to determine what type 
of model file it is checking. For this purpose, it is imperative that the model file name is correct.  
 
Model File Name 
 
For the current release of the A/E/C CADD Standard (Release 2.0), the Checker will scan a 
design for compliance with the standard based on the discipline designator and model file code 
assigned in the file name.  See Appendix A for the list of available codes.  The A/E/C CADD 
Standard file naming convention is based on the U.S. National CAD Standard (NCS) with one 
exception, it has a 0-20 character Project Code field which the NCS does not.   
 
@  F-  KP XXXX. dgn/dwg 
    
   User definable 
   Model file type 
   Discipline Designator* 
                              * The second character is always a "-" 
 
   Project code(0-20 characters) 
 
A/E/C CADD Standard Model File naming 
method 
 

     F-  KP XXXX. dgn/dwg 
    
   User definable 
   Model file type 
   Discipline Designator* 
                            * The second character is always a "-" 
 
 
 
National CAD Standard Model File naming 
method 
 

 
Sheet File Name 
 
The A/E/C CADD Standard's Sheet file naming convention is also based on the NCS with one 
exception; it contains a field for assigning Project code.  The same 0-20 character field is added to 
this naming method as in the Model file name convention.  See Appendix A for the list of 
available codes. 
 
 @  A-  1  02 XXX.  dgn/dwg 
    
   User definable 
   Sheet sequence number 
   Sheet type designator 
   Discipline designator 
   Project code 
 
A/E/C CADD Standard Sheet File naming 
method 
 

A-   1   02   XXX.  dgn/dwg 
    
    
   User definable 
   Sheet sequence number 
   Sheet type designator 
   Discipline designator 
 
National CAD Standard Sheet File naming 
method 
 

 
Note: The user-defined field of both the Model Sheet file name must be filled to the maximum 
number of characters the fields will hold.  For example DEMOA-FP001.dwg/dgn would be 
incorrect and DEMOA-FP001X.dwg/dgn would be correct for Model file naming. 
DEMOA-102X.dwg/dgn would be an incorrect Sheet file name and DEMOA-102XXX.dwg/dgn 
would be correct. 
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Exercise 1-1: A Quick File Naming Exercise 
 
Using Appendix A in the back of this manual, generate a compliant name for the following 
model/sheet files. Write the name in the blank provided.  
 
•= The Project Code is OLD for Olmsted Locks and Dams 
•= Use 01 for all sheet sequence numbers if needed. 
•= Use X for all unused user definable characters.  
•= The Sheet Type (if needed) is a Details sheet. 
 
 

Model/Sheet File A/E/C CADD Standard 
Hydrographic Survey Plan  
Civil Dredging Plan  
Civil Elevation  
Civil Detail  
Civil Site Plan  
General Border Sheet  
Geotechnical Boring Log  
Civil Transportation Site 
Plan 

 
Civil Details Sheet File  
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 File Manager 
 
To assist users in naming project files that comply with the A/E/C CADD Standard file naming 
convention, a File Manager tool (Figure 1) was developed.  
 

 

Figure 1 The File Manager interface used to name design files. 
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                         Workspace Functionality 
 
 
 
 
 
 
Workspace Background 
 
The Workspace consists of four major parts: menus, resource files, cell libraries and the checker. 
Each of these components plays a vital part in the overall functionality of the workspace. The 
menus are used to interface with the user. These menus pull their intelligence from the resource 
files and cell libraries to aid the user in creating A/E/C Standard-compliant drawings. The 
checker is the last step in ensuring the overall compliance to the standard by informing the user of 
non-compliant elements. 
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General Overview 
 
The A/E/C CADD Standard is implemented transparently through the Workspace. With the 
Workspace, the user is no longer required to hunt through the Standard for level symbology 
settings.  Once the Workspace is installed, the A/E/C Standard pull-down menu (Figure 1) is 
immediately available upon opening design files. Most of the Workspace's dialog boxes and 
palettes work in exactly the same manner as standard MicroStation dialog boxes and palettes and 
should be very easy for the experienced user to maneuver through the interface. 
 

 
Figure 1 – MicroStation TSWS Interface 
 
 
Each discipline listed in the TSWS pull-down menu expands to show the corresponding model 
files (Figure 2). For example, the Architectural discipline has a sheet file and eight model files: 
Area Calculations/Occupancy Plan, Details, Elevations (Exterior and Interior), Equipment Plan, 
Floor Plan, Reflective Ceiling Plan, Roof Plan, and Building Sections.  Once a model file is 
selected, the user will be prompted for a drawing scale. The drawing scale selected will affect the 
size of placed text, symbols and patterning elements. Once the drawing scale is selected, a palette 
for the model file chosen will appear (Figure 3).  Each palette contains icons representing the 
different types of elements that can be drawn in that model file (e.g., doors, windows, walls, etc.). 
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Figure 2 – Discipline Pull-Down Menu 

 
Figure 3 – Model File Palette 
 
 
Levelbox Preferences 
 
The Levelbox (Figure 4) in the A/E/C Workspace is used for selecting the level that elements will 
be placed on. This will be the main utility that users will use in selecting the attributes that 
comply with the A/E/C CADD Standard. Levelbox Preferences, under the TSWS pull-down 
menu, is used to modify how the Levelbox operates.  

Figure 4 – Levelbox 
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Opening the Levelbox Preferences 
 
1. Select TSWS from MicroStation pull-down menu. 
 
2. Pick Levelbox Preferences from the bottom of the pull-down (Figure 5). 

Figure 5 – Opening the Levelbox Preferences 
 
Changing the Levelbox Preferences 
 
The Levelbox Preferences dialog box (Figure 6) is available to allow the user to modify the 
vertical size and functionality of the Levelbox.  
 

 
Figure 6 – Levelbox Preferences settings dialog box 
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Docked Row Count 
 
The Docked Row Count setting allows the user to change the number of levels displayed in the 
Levelbox, when docked into the MicroStation interface (Figure 7). The default is “2”. 
 

 
Figure 7 – Levelbox docked into MicroStation’s interface 
 
 
Undocked Row Count 
 
When the Levelbox is undocked (Figure 8), the Undocked Row Count setting allows the user to 
change the number of levels displayed in the dialog box. The default is “6”. 

Figure 8 – Undocked Levelbox 
 
 
Double Click Row to Activate 
 
The Double Click Row to Activate setting can be used to allow for single or double clicking 
when selecting a level in the Levelbox. 
 
 
Command Filter 
 
Selecting an option in the Levelbox will sometimes change the active attribute and also enter the 
user into an element placement command. The Command Filter (Figure 9) allows for Smartline, 
Line or Linestring to be selected as the default element placement type for the Workspace. In 
addition, the Use AccuDraw setting allows the user to automatically start AccuDraw each time 
the default element placement type is used. 
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Figure 9 – Levelbox Preferences Command Filter 
 
 
 
Workspace Version 
 
Selecting TSWS Version at the bottom of the TSWS pull-down allows the user to see the current 
version of the Workspace in use and the database used to generate the Workspace (Figure 10).  
The user should have this information handy to report to the Center if an error/bug is ever found 
in the Workspace. 
 

 
Figure 10 – Workspace Version Dialog Box  
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Architectural Discipline 
 
 
 
In this Chapter  
 
In this chapter, we will explore the interface, compliant element placement, and the many model 
files in the Architectural Discipline. Both an Architectural model and sheet file will be created. 
The Architectural Discipline levels are divided into the 9 model/sheet files listed below: 
 

•= Floor Plan  
•= Reflected Ceiling Plan 
•= Roof Plan 
•= Elevations (Exterior and Interior) 
•= Building Sections 
•= Details 
•= Equipment Plan 
•= Area Calculations/Occupancy Plan 
•= Sheet File 

 
Each of these model/sheet files has the necessary symbology and standard symbols for creating 
standard compliant drawings. 
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Exercise 3-1: Creating a Model File 
 
Creation of model files is often the first step in the process of developing engineering documents. 
In this exercise, we will create a model file using a standard compliant name and proceed to place 
elements that are compliant with the A/E/C CADD Standard. 
 
Creating a Model File 
 
The first step is the creation of the file. In this exercise, we will create a floor plan model file.  It 
is very important that the proper seed file is used so that working units and other settings are 
accurate for this type of model file.  Just as important is the name of the file. The checker uses the 
file name when verifying compliance with the A/E/C CADD Standard.  
 
1. Start MicroStation.  
 

We need to be at the MicroStation Manager dialog box. 
 
2. Open the Create Design File dialog box. (File>New) 
 
3. From the bottom of the 

Create Design File 
dialog box in the Seed 
File section, pick Select. 

 
This will open the Select 
Seed File dialog box. 

 
4. From the TSWS/seed 

directory select 
I_AEC_3D.DGN seed 
file.  

 
This file uses inch-pound 
units and has working 
units set to feet and 
inches with MU:SU:PU 
set to 1:12:8000. 

 
5. Select OK. 
 
6. Keyin a file name of B2CA-FP0001.DGN as the new file to create. 
 

The file B2CA-FP0001.DGN uses the optional model file naming convention (B2C = project 
code, A- = Architectural discipline, FP = Floor Plan model file, 0001 = user definable 
characters). 
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7. Select OK to create the file. 
 
8. Select OK to open the file. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Create a Small Floor Plan 
 
In this section, we will create a small 20’ x 30’ floor plan with a 3’ door.  
 
1. Select Floor Plan from the Architectural discipline under the TSWS pull down menu 

(TSWS>Architectural>Floor Plan). 
 

 
 
 

2. From the Select Scale dialog 
box, select the ¼”=1’ scale. 

 
3. Select OK. 
 

Setting the scale will 
automatically adjust the 
placement size of certain 
elements (text, cells and 
patterns). 
 
Once the drawing scale has been selected, the Architectural Floor Plan toolbox will display. 
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4. From the Floor Plan toolbox select the Walls icon. 
 
5. Inside of the Levelbox select Exterior full height walls. 
 

This will change the active settings inside of MicroStation to the compliant symbology for 
exterior full height walls. 

 
6. Create a 20’ x 30’ building outline shape using the SmartLine or place block command in the 

top view (Window 1). 

7. Using the copy parallel command, create a 1’ thickness to the walls.     
 
8. From the Floor Plan toolbox, select the Doors 

icon. 
 

This will open the Doors Levelbox with the 
door levels listed. 

 
9. Select the Partial height door: swing and 

leaf level from the levelbox. 
 

This will open the toolbox for partial 
height doors. 

 
 
 
10. From the Partial Height Doors toolbox, select the 

Left Double Door icon. 
 

This will open the cellbox with the options for the door size. 
 

11. From the Cellbox, select the 6’-0” Left Double 
Door. 

 
At this point, MicroStation will activate the 
place active cell command with the proper cell 
name (DORDBL) and scale. 

 
12. Place the door at the bottom center of the floor plan. 
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Your design should look like the following: 
 
 

 
 
13. It will be necessary to clean up the existing wall with the partial delete command, trim off 

any excess lines, and place the door header lines. 
 
Notes:  
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Exercise 3-2: Creating a Sheet File 
 
A sheet file is a file used for plotting final construction documents.  Creation of a sheet file 
involves referencing various model files and editing the reference file attachments with clipping, 
scaling and layer display functions in order to create the desired construction document. Finally, 
sheet file specific information is placed in the active design (border sheet text, scales, north 
arrows, etc).  In this exercise, we will be referencing four (4) model files and adding sheet file 
specific text to create a sheet file.   
 

 
 
Create a New Sheet File 
 
In this next section we will create a sheet file. For this sheet file we will be using a metric seed 
file to match the model files' working units. The creation of the sheet file will have less detail 
than the previous exercise. 
 
1. Start MicroStation 
 

We need to be at the MicroStation Manager dialog box. 
 
2. Open the Create Design File dialog box. (File>New). 
 
3. From the bottom of the Create Design File dialog box in the Seed File section, pick Select. 
 

This will open the Select Seed File dialog box. 
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4. From the TSWS/seed directory select M_AEC_3D.DGN seed file.  
 

This file uses metric units and has working units set to mm with MU:SU:PU set to 1:1:100. 
 
5. Select OK. 
 
6. Keyin a file name of FWAA-101AXX.DGN.dgn as the new file to create. 
 

The file FWAA-101A.DGN uses the optional sheet file naming convention (FWA = project 
code, A- = Architectural discipline, 1 = Plan, 01 = sheet sequence number, AXX = user 
definable character). 

 
7. Select OK to create the file. 
 
8. Select OK to open the file. 
Once we have the sheet file opened, we need to reference all four (4) of the model files used in 
this sheet file. 
 
Attaching the Floor Plan Model File 
 
1. Open the Reference Files dialog box (File>Reference). 
 
2. Open the Attach Reference File dialog box (Tools>Attach). 
 
3. Navigate to the class directory and select the floor plan model file FWAA-FP0001.DGN. 
 
4. Select OK. 
 
5. Keyin a logical name of AFP in the Attach Reference File dialog box. 
 
6. Keyin a description of FLOOR PLAN in the Attach Reference File dialog box. 
 
7. Verify that the Nest Depth is set to 0.  
 

A nest depth greater than 0 will result in any reference file that is attached to the file also 
being attached as a separate reference file attachment. This is usually not the desired result. 

 
8. Select OK. 
 
9. Use the Fit command to view the reference file. 
 
10. Place a fence around the area on the far-left side of the floor plan to be used. 
 
11. From the Reference Files dialog box, select the Clip Boundary command (Tools>Clip 

Boundary). 
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Your drawing should look like the following: 
 

 
 
Attaching the Furniture Plan Model File 
 
1. Open the Reference File dialog box (File>Reference). 
 
2. Open the Attach Reference File dialog menu (Tools>Attach). 
 
3. Navigate to the class directory and select the furniture plan model file FWAI-RP0001.DGN 

(Note: this is an Interior Design model file, I- = Interior Design, RP = Furniture Plan). 
 
4. Select OK. 
 
5. Keyin a logical name of IRP in the Attach Reference File dialog box. 
 
6. Keyin a description of FURNITURE PLAN in the Attach Reference File dialog box. 
 
7. Verify that the Nest Depth is set to 0.  
 
8. Select OK. 
 
9. Place a fence around the area of the furniture plan to be used. 
 
10. From the Reference Files dialog box select the Clip Boundary command (Tools>Clip 

Boundary) 
 
 
 



  Course Guide 
 

A/E/C CADD Standard Workspace 2.0 Course Guide  3-9  

 
Your drawing should look like the following: 

 
 
 
Attaching the Column Plan Model File 
 
1. Open the Reference File dialog box (File>Reference). 
 
2. Open the Attach Reference File dialog box (Tools>Attach). 
 
3. Navigate to the class directory and select the column plan model file FWAS-CP0001.DGN 

(Note: this is a Structural model file, S = Structural, CP = Column Plan). 
 
4. Select OK. 
 
5. Keyin a logical name of SCP in the Attach Reference File dialog box. 
 
6. Keyin a description of COLUMN PLAN in the Attach Reference File dialog box. 
 
7. Verify that the Nest Depth is set to 0.  
 
8. Select OK. 
 
9. Place a fence around the area of the column plan to be used. 
 
10. From the Reference Files dialog box select the Clip Boundary command (Tools>Clip 

Boundary) 
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Your drawing should look like the following: 

 
 
 
Attaching the Border Sheet model file 
 
1. Open the Reference File dialog box (File>Reference). 
 
2. Open the Attach Reference File dialog box (Tools>Attach). 
 
3. Navigate to the class directory and select the border sheet model file FWAG-BS0000.DGN 

(Note: this is a General model file, G- = General, BS = Border Sheet). 
 
4. Select OK. 
 
5. Keyin a logical name of GBS in the Attach Reference File dialog box. 
 
6. Keyin a description of BORDER SHEET in the Attach Reference File dialog box. 
 
7. Verify that the Nest Depth is set to 0.  
 
8. Select OK. 
 
9. Scale the reference file up to fit around the floor plan. Select the Scale Reference File 

command from the Reference Files dialog box (Tools>Scale). 
 
10. Enter in a scale of 100 to 1. 



  Course Guide 
 

A/E/C CADD Standard Workspace 2.0 Course Guide  3-11  

 
 
 
11. Identify a point to scale the reference file about with a data point inside of the view. 
 
12. Move the Border Sheet model file to the proper location using the Reference Move command 

(Tools>Move). 
 

Your drawing should look like the following: 

 
Turn off the Border Sheet Grid Lines 
 
If desired, the border sheet grid lines can be turned off. These lines reside on level 3 of the border 
sheet model file. Using the reference file dialog box, we can turn off and on levels in a reference 
file without affecting the active file’s elements. 
 
1. Open the Reference Files dialog box (File>Reference). 
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2. Select the border sheet model file reference attachment. 
 

 
 
3. Open the Reference Levels dialog box 

(Settings>Levels). 
 
4. Toggle level 3 off. 
 
5. Select All. 
 

Selecting All will make the change effective on 
all windows (1 through 8) of the active design 
file. Selecting the Apply button will only affect 
the view that is currently selected at the top of 
the dialog box. 

 
6. Dismiss the dialog box by selecting the X at the 

top right side of the Reference Levels dialog box. 
 

This method of turning off and on levels of 
attached reference files has no effect on the elements in the active file. 

 
 
Adding Title Block Text 
 
Inside of the title block you would need to add a few lines of text. For example, a drawing 
description of FLOOR PLAN needs to be added. For additional practice, place text in the design 
file information area, such as name, date, file name, etc.  
 
1. Open the Floor Plan toolbox (TSWS>Architectural>Sheet File). 
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2. Select the 1mm = 100mm scale from the 
Select Scale dialog box. 

 
This is the plot scale of the sheet file. It also 
corresponds to the current scale of the border 
file used. This will change the size of the text 
to be correct upon placement. 

 
 
 
 
 
 
 
3. Select the General Information icon from the Sheet File toolbox. 
 
4. From the levelbox, select the Sheet-specific text and callouts with associated leaders (e.g., 

title block text, legend and schedule text) level. 
 
5. Select the Place Text command. 
 
6. Keyin FLOOR PLAN in the text editor. 
 
7. Set the active angle to 90°. 
 
8. Place the text below the line that has AIR PASSENGER TERMINAL. 
 
9. Practice using the place text command for placing other text in the title block. 
 
 
Notes:  
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Electrical Discipline 
 
 
 
In this Chapter 
 
In this chapter, we will explore the Electrical Discipline of the Workspace. This chapter will 
contain less detail on many of the commands covered in the previous chapter. The Electrical 
Discipline levels are divided into the 10 model/sheet files listed below: 
 

•= Lighting Plan 
•= Power Plan 
•= Special Systems Plan 
•= Grounding System 
•= Electrical Utilities Plan 
•= Exterior Communication Systems Plan 
•= Riser/One-Line Diagrams 
•= Airfield Lighting Plan 
•= Details 
•= Sheet File 

 
Each of these model/sheet files has the necessary symbology and standard symbols for creating 
standard compliant drawings. 
 
We will first add compliant elements to finish an existing model file. Then we will create a new 
sheet file by attaching the necessary model files. 
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Exercise 4-1: Working with Model Files 
 
Working with model files represents a majority of the use of the Workspace. In this exercise, we 
will open an existing model file and complete the design using compliant elements selected with 
the workspace. 
 
Opening the Model File 
 
We need to first open the model file and select the proper model file toolbox. 
 
1. Start MicroStation 
 

We need to be at the MicroStation Manager dialog box. 
 
2. Select file E01E-LP0001.DGN from the class directory. 
 
3. Select OK. 
 
4. Based on the file name E01E-LP0001.DGN select the correct model file from the TSWS pull-

down menu (TSWS>Electrical>Lighting Plan). 
This will open the toolbox for this model file. 

 
5. Turn the display on for the floor plan reference file E01A-FP0001.DGN 
 

This will display the Architectural floor plan model file. Model files from other disciplines 
can be referenced to create other discipline's model and sheet files.  
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Adding Lighting Circuits 
 
In this section you will add the lighting circuits that are missing. 
 
1. Zoom into the bottom right side of the floor plan (Mechanical Room). 

 
2. Select the Circuit Lines icon from the Lighting Plan toolbox. 
 
3. From the levelbox, select Lighting Circuits.  Then select the line command from the palette. 
 
4. Create the missing lighting circuits. 
 
Your completed circuits should look like the following: 
 

 
 
 
Adding Light Fixtures and Circuits 
 
1. Zoom into the office in the top left side of the building.  
 
2. From the Lighting Plan toolbox select the Lighting 

icon. 
 

3. Select Ceiling Mounted Fixtures from the levelbox. 
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4. Select the 2 X 2 Light Fixture icon.  
 
Then select 600 X 600 Light Fixture from the Cellbox. This places a 600 x 600 fluorescent 
fixture. After placing one, continue placing the remaining three fixtures in the office. 

 
Add Lighting Circuits for the Light Fixtures 
 
1. Select the Circuit Lines icon from the Lighting Plan toolbox. 

 
2. From the levelbox, select Lighting Circuits. 
 
3. Create the missing lighting circuits. 
 
Place Light Fixture Identification Tags 
 
In this section we will place light fixture identification tags to correspond with the lighting 
schedule. 
 
1. From the Lighting Plan toolbox select the Lighting icon. 

 
2. Select Light fixture identifier tags from the levelbox. 
 
3. Place the letter “P” next to each of the newly placed light fixtures. 
 
 
Your completed lights and circuits should look like the following: 
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Exercise 4-2: Creating Electrical Sheet Files 
 
In this exercise, we will create a new sheet file, then reference all necessary model files.  The 
completed sheet file should look like the following: 
 

 
 
Create a New Sheet File 
 
In this next section, we will create a sheet file. For this sheet file, we will be using a metric seed 
file to match the referenced model files' working units.  
 
1. Start MicroStation. 

We need to be at the MicroStation Manager dialog box. 
 
2. Open the Create Design File dialog box (File>New). 
 
3. From the bottom of the Create Design File dialog box in the Seed File section, pick Select. 
 

This will open the Select Seed File dialog box. 
 

4. From the TSWS/seed directory select the file M_AEC_2D.DGN from the list. 
 

This file uses metric units and has working units set to mm with MU:SU:PU set to 1:1:100. 
 
5. Select OK. 
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6. Keyin a file name of E01E-401AXX.DGN as the new file to create 
 

The file E01E-401AXX.DGN uses the optional sheet file naming convention (E01 = project 
code, E- = Electrical discipline, 4 = Large scale plan, 01 = sheet sequence number, AXX = 
user definable character).  

 
7. Select OK to create the file 
 
8. Select OK to open the file 
 
 
Attaching the Model Files 
 
Once we have the sheet file opened, we need to attach all of the model files used for this sheet 
file. The model files used for this sheet file include: 
 
•= E01A-FP0001.DGN (Two times) 
•= E01E-LP0001.DGN 
•= E01E-PP0001.DGN 
•= E01E-DT0001.DGN 
•= E01G-BS0001.DGN 
•= E01G-KP0001.DGN 
 
1. Open the Reference Files menu (File>Reference) or (TSWS>Electrical>Sheet File). 
 
2. Open the Attach Reference File dialog box (Tools>Attach). 
 
3. Navigate to the class directory and select the floor plan E01A-FP0001.DGN 
 
4. Select OK 
 
5. Keyin a logical name of AFP1 in the Attach Reference File dialog box 
 
6. Keyin a description of TOP FLOOR PLAN  in the Attach Reference File dialog box 
 
7. Verify that the Nest Depth is set to 0  
 
8. Select OK 
 
9. Use the Fit command to view the reference file 
 
10. Place a fence around the floor plan to be used 
 
11. From the Reference Files dialog box, select the Clip Boundary command (Tools>Clip 

Boundary). 
 

Repeat these steps to model files E01A-FP0001 (second attachment), E01E-LP0001, and 
E01E-PP0001. 
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Move and Scale Model Files 
 
1. Attach the border sheet model file and scale it 50:1.  Move the border sheet so that it contains 

the plans you referenced in the above steps. 
 
2. Attach the Electrical Detail model file and the Keyplan model file.  Scale them 50:1 if 

necessary. 
 
3. Move all reference files to the proper locations. 
 
4. Create clip boundaries where needed. 
 
5. Adjust reference file levels where needed. 
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Civil Discipline 
 
 
 
 

 
 
In this Chapter 
 
In this chapter, we will explore the Civil Discipline of the Workspace. The Civil Discipline levels 
are divided into the 18 model/sheet files listed below: 
 

•= Site Plan 
•= Grading Plan 
•= Dredging Plan 
•= Transportation Site Plan 
•= Joint Layout Plan 
•= Airfield Plan 
•= Airfield Paving Plan 
•= Domestic Water Plan 
•= Sanitary Sewer Plan 
•= Storm Sewer Plan 
•= Industrial Waste Water Plan 
•= Natural Gas Utilities Plan 
•= Liquid Fuel Utilities Plan 
•= Profiles 
•= Elevations 
•= X-Sections 
•= Details 
•= Sheet File 

 
Each of these model/sheet files contains the necessary symbology and standard symbols for 
creating standard compliant drawings. 
 
We will first place compliant elements to finish an existing model file.  Then we will create a new 
sheet file by attaching the necessary model files.  
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Exercise 5-1: Working with Model Files 
 
In this exercise we will use a pre-existing civil model file to demonstrate working with existing 
data.   
 
Opening the Model File 
 
1. Start MicroStation 
 
2. Open file ITLC-SP0001.DGN from the class directory 
 
You should see the following drawing: 
 

 
In this next section, we will attach other reference files and finish placing elements using the 
workspace in this Site Plan model file. 
 
Referencing other Model Files 
 
Model files can be used to create both sheet files and other model files.  For this exercise, we will 
reference in a Civil Transportation Site Plan model file, to assist in the placement of fencing. 
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1. Since we will not need the Topography levels for this exercise, turn off those levels so the 
design file can be easily read (LV 41-44). 

 
 
2. We could start placing fencing now, but the current design file does not contain the linework 

for the parking lot or driveways.  So, we will have to reference in the Transportation Site 
Plan. 

 
3. Open the Reference File dialog box (File>Reference). 
 
4. Open the Attach Reference File dialog box (Tools>Attach), and select ITLC-TS0001.DGN. 
 
5. Select OK. 
 
6. Keyin a logical name in the Attach Reference File dialog box. 
 
7. Keyin a description in the Attach Reference File dialog box. 
 
8. Verify that the nest depth is set to 0. 
 
9. Select OK. 
 
10. Use the Fit command to view all files. 
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Adding Elements into the Model File 
 
1. Zoom into the bottom center of the file where the two storm drainage lines are located. 
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2. The storm drainage lines are there, but there are not any 
catch basins or manholes!  We will now add these items 
using the workspace.  Select the Storm Drainage icon from 
the Site Plan toolbox (TSWS>Civil>Site Plan). 

 
3. From the levelbox, select Storm drainage, headwalls, inlets, manholes, culverts, and 

drainage structures.  A palette will appear with the option to either draw linework or place an 
existing symbol from the Civil/Site library.  In 
this case, we want to use the Storm drainage 
manhole symbol. 

 
4. Place storm drainage manholes at both junctures of the storm drainage lines. 

 
5. Now to place the Catch Basins.  From the Storm drainage, headwalls, inlets, manholes, 

culverts, and drainage structures palette, select the symbol for square Catch Basins. 
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6. Now, place the Catch Basins at the upper ends of the two Storm Drainage lines. 
 

 
 
7. We will now place a partial fence line around the Site Plan.  Select 

the Site Improvement icon from the Site Plan toolbox. 
 
8. From the levelbox, select Fences and handrails. 
 
9. Note that when you selected this 

level, you have a choice of using 
either a single line (continuous) or 
the FENCE custom linestyle.  
Select the Fence linestyle.  Let's 
verify that the linestyle will be 
placed at the correct scale factor.  
Click on the FENCE linestyle 
name and then select Custom.  On 
the Line Styles dialog box, click on 
the Show Details box.  The scale 
factor should be 480 since the 
design file was created for a plot 
scale factor of 1" = 40'. 
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10. Select the Fences level again from the levelbox and begin drawing a fence around the exterior 
of the driveway.  When you finish, you should have something like this: 

 
 
11. Detach the Transportation Site Plan reference file and save the Site Plan.  Remember: a 

model file should never be saved with reference files attached. 
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Exercise 5-2: Creating Civil Sheet Files 
 
In this exercise we will create a new Civil sheet file using files from the previous exercise.  
 
The completed sheet file should look like the following: 
 
 

 
 
Create a New Sheet File 
 
In this next section we will create a sheet file. For this sheet file we will be using an inch-pound 
seed file to match the model files' working units.  
 
1. Start MicroStation 
 
2. Open the Create Design File menu (File>New) 
 
3. From the bottom of the dialog box in the Seed File section, pick Select. 
 

This will open the Select Seed File dialog box. 
 

4. From the TSWS/seed directory select the file I_CIV_3D.DGN from the list 
 

This file uses inch-pound units and has working units set to ft with MU:SU:PU set to 
1:100:10. 

 
5. Select OK 
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6. Keyin a compliant name for a Civil sheet file with a Plan being the dominant feature on the 
sheet. 

 
7. Select OK to create the file 
 
8. Select OK to open the file 
 
 
Attaching the model files 
 
Once we have the sheet file created we need to attach all of the model files used for this sheet file. 
The model files used for this sheet file include: 
 
•= ITLC-SP0001.DGN 
•= ITLC-TS0001.DGN 
•= ITLG-BS0001.DGN 
 
 
1. Open the Reference File menu (File>Reference) or (TSWS>Civil>Sheet File) 
 
2. Open the Attach Reference File dialog box (Tools>Attach) 
 
3. Navigate to the class directory and select one of the reference files. 
 
4. Select OK 
 
5. Keyin a logical name in the Attach Reference File dialog box 
 
6. Keyin a description in the Attach Reference File dialog box 
 
7. Verify that the Nest Depth is set to 0  
 

A nest depth of greater that 0 will result in any reference file that is attached to the file will 
also be attached as a separate reference file attachment. This is not usually the desired result. 

 
8. Select OK 
 
9. Use the Fit command to view the reference file 
 
10. Place a fence around the area to be used 
 
11. From the Reference Files dialog box select the Clip Boundary command (Tools>Clip 

Boundary) 
 

Repeat these steps to attach all of the model files listed above 
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Move and Scale Model Files 
 
1. Scale the border model file to fit around the design. We will scale the border at half the size 

of the plot scale. (Hint: the plot scale used is 1" = 40'). 
 
2. Move reference files to the proper locations. 
 
3. Create clip boundaries where needed 
 
4. Adjust reference file levels where needed 
 
This completes the Civil chapter.  
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Checker Dialog Box 
 
 
 
 
A/E/C Standard Checker 
 
This chapter is designed to familiarize the user with the A/E/C Standard Checker. We will 
examine the Checker interface and interpret the output results in the Checker report.  
 
The Checker is a tool that is intended to give the user feedback on how compliant design files are 
with the A/E/C CADD Standard.  The Checker is automatically executed upon startup of any 
MicroStation design file (unless disabled).  The Checker should be used only to test model files 
(without any reference files attached).  It should not be used on sheet files, due to the various 
disciplines that could be referenced together to create a sheet file. 
 
 
Exercise 6-1: Using the Checker Dialog Box 
 
In this exercise, we will open an Architectural model file and work through the interface of the 
checker.  
 
Using Locate 
 
1. Start MicroStation 
 
2. Open the file FWAA-FP0001.DGN from the class directory 
 

This design file is a large floor plan. It is a compliant drawing with a few non-compliant 
elements placed inside.  
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3. From the TSWS pull-down menu, select the Checker (TSWS>Checker Dialog) 
 

This will open the Checker dialog box. 

 
Notice the three elements that are listed inside of the A/E/C Standards Checker dialog box. 
These three items have some property that is non-compliant with the A/E/C CADD Standard.  
The three columns in the dialog box have information about the elements that are found to be 
non-compliant. The first column is the type of element (Arc, Ellipse, Cell, etc.). The second 
column lists the type of error that the checker found. The last column tells whether the item 
has an attribute linked to it.  
 

4. Verify that the view number listed at the top right matches the view you have open.  
 
 

5. Select the first element in the list.  This will be the Arc. 
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6. Click on the Locate button. 
 
MicroStation will now zoom into the area around the Arc and highlight the Arc element.  
From looking at this item, we now know that there is something non-compliant with the 
symbology of this door swing. 
 

 
7. Repeat the process of locating each element in the list 
 
Using Statistics 
 
In this section, we will check the statistics for the design file, correct a non-compliant element, 
and recheck the statistics. 
 
1. From the TSWS pull-down menu, select the Checker (TSWS>Checker Dialog) 
 
2. From the Checker dialog box, select Statistics 
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You should see the following information box: 
 

 
   

This information tells us that the design file contains 3 non-compliant elements at the time of 
the Checker scan (8832 total items - 8829 compliant items = 3 non-compliant items).  This 
information is sent to a database for record keeping. 
 

� The Elapsed time will be different each time the statistics are displayed. 
 
3. Select OK to dismiss the Information dialog box. 
 
 
Changing Elements and Resample 
 
1. From the A/E/C Standards Checker dialog box, select the first element in the list. 

This will be the Arc used for a door swing. 
 

2. Select Locate to zoom in to the non-compliant arc. 
 
3. Open the Architectural Floor Plan toolbox (TSWS>Architectural>Floor Plan) 
 
4. Select the Doors icon 
 
5. From the Levelbox, select Partial height door: swing and leaf then click on the line icon in 

the Partial Height Doors palette.  This will change the active symbology inside of 
MicroStation. 

 
6. Using the Change Element Attribute command, 

modify the Arc's symbology. 
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7. Select Statistics from the checker dialog box. 
 

 
 
This time the statistics reflect the change in compliant element total (there are now only two 
non-compliant elements). 

 
8. Select Resample 
 

This will update the listing in the Checker dialog box to reflect the new compliance status of 
the design file. Both Statistics and Resample force the checker to re-check the design file. On 
very large drawings or slower machines it may be necessary to avoid selecting these 
commands repetitively. 

 

 
 
Change the Symbology of the Two Non-Compliant Ellipses 
 
1. Use the Locate on the Checker dialog box to find the ellipses 
 

Circles are displayed as an ellipse internally to MicroStation. 
 
2. Select the Columns icon from the  

Floor Plan toolbox. 
 
3. From the Levelbox, select Column enclosures/fire protection. 
 

This will adjust the active symbology to the proper settings. 
 



  Course Guide 
 

A/E/C CADD Standard Workspace 2.0 Course Guide  6-6 

4. Using the Change Element Attribute command, modify the 
non-compliant column enclosure's symbology. 

 
5. Verify the compliance by using the Resample command inside of the A/E/C Standards 

Checker dialog box.  Repeat the above process on the other non-compliant column enclosure. 
 

 
Statistics and Resample 
 
At this point in the design file, when the floor plan is Resampled, the model file should be 100% 
compliant with the A/E/C CADD Standard. 
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Exercise 6-2: Checking an Existing Civil Model File 
 
In the following Civil Grading Plan model file, we will change non-compliant elements to be 
compliant. Less detail will be given during this exercise than with exercise 6-1. The final 
outcome of this exercise should be a 100% compliant drawing. 
 

 
 
1. Start MicroStation 
 
2. Open the file EJAC-GP0001.DGN from the class directory 
 

This design file is a Grading Plan. It is a compliant drawing with three non-compliant 
elements placed inside (contour lines).  
 

3. Open the Civil Grading Plan toolbox 
(TSWS>Civil>Grading Plan) 
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4. Select the Topography icon 
 
 
5. From the Levelbox, use the Major Contour 

and Minor Contour levels to set correct 
symbology. 

 
 
 
 
 
6. Using the Change Element Attributes 

command, modify the symbology of the non-
compliant elements. 

 
 
The final result should be a 100% A/E/C CADD Standard-compliant model file. 



      Course Guide 
 

A/E/C CADD Standard Workspace 2.0 Course Guide  A-1  

 

 
File Naming Guide 

 
 
 
 
TABLE 1 
Discipline Designators 
 

 

Discipline Character 
General G 
Hazardous Materials H 
Survey/Mapping V 
Civil Works W 
Civil C 
Geotechnical B 
Landscape  L 
Structural S 
Architectural A 
Interiors I 
Equipment Q 
Fire Protection F 
Plumbing P 
Mechanical M 
Electrical E 
Telecommunications T 
Resource R 
Other Disciplines X 
Contractor/Shop Drawings Z 
Operations O 
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TABLE 2 
Model File Types 

  

Discipline Code                 Definition 
General (G)   
 BS Border Sheet 
 KP Keyplan 
Survey/Mapping 
(V) 

  

 CP Existing Communication 
Plan 

 EU Existing Electrical 
Utilities Plan 

 FU Existing Liquid Fuel 
Utilities Plan 

 HP Hydrographic Survey Plan 
 IW Existing Industrial Waste 

Water Plan 
 NG Existing Natural Gas 

Utilities Plan 
 PR Existing Profile 
 SC Existing Section 
 SP Survey/Mapping Plan 
 SS Existing Sanitary Sewer 

Plan 
 ST Existing Storm Sewer 

Plan 
 WA Existing Domestic Water 

Plan 
Civil (C)   
 LG Legend 
 AF Airfield Plan 
 AM Airfield Pavement 

Marking Plan 
 CP Channel Plan 
 DT Detail 
 DP Dredging Plan 
 EL Elevation 
 FU Liquid Fuel Utilities Plan 
 GP Grading Plan 
 SH Schedule 
 IP Installation Plan/Base 

Map 
 IW Industrial Waste Water 

Plan 
 JP  Joint Layout Plan 
 KP Staking Plan 
 NG Natural Gas Utilities Plan 
 PL Project Location Map 
 PR Profile 
 QP Equipment Plan 
 SC X-Section 
 SP Site Plan 
 SS Sanitary Sewer Plan 
 ST Storm Sewer Plan 
 TS Transportation Site Plan 
 WA Domestic Water Plan 
 XD Existing/Demolition Plan 
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TABLE 2 
Model File Types 

 (Continued) 

Discipline Code                 Definition 
Geotechnical (B)   
 BL Boring Location Plan 
 LB Boring Log 
 LG Legend 
 SH Schedule 
 
 
 

TABLE 3 
Sheet Type Designators 
 

 
 
 

Sheet Type Character 
General (symbols, legend, notes, etc.) 0 
Plans (horizontal views) 1 
Elevations (vertical views) 2 
Sections (sectional views) 3 
Large Scale Views (plans, elevations, or sections that are not 
details) 

4 

Details 5 
Schedules and Diagrams 6 
User Defined 7 
User Defined 8 
3D Views (isometrics, perspectives, photographs) 9 
 
 
For more information and additional model file types, see A/E/C CADD Standard Release 
2.0 or the National CAD Standard, Release 2.0.
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